title: Brocade FastIron Switches
breadcrumbs:
- title: Network
---
{% include header.md %}
Using
{:.no_toc}
- Brocade/Ruckus ICX 6610 (v08.0.30 router edition).
Disclaimer
{:.no_toc}
Security features like port security, dynamic ARP inspection, DHCP snooping, IP source guard, DHCPv6 snooping, IPv6 NDP inspection and IPv6 RA guard will not be covered since I mainly use the switch as a core/dist. switch and not an access switch.
Initial Configuration
- Connect using serial: 9600bps baud, 8 data bits, no paroty, 1 stop bit, no flow control.
- Enter privileged exec mode:
enable
- Enter configuration mode:
conf t
- Shut down all interfaces:
- Alternatively, shut down unused interfaces afterwards.
- Select range of innterfaces:
int e1/1/1 to 1/1/24
(example)
- Shut them down:
disable
- Repeat for other interface ranges.
- Set the correct boot preference:
- Change it:
boot system flash primary
- Check it (priv exec):
sh boot-pref
- Set the hostname:
hostname <name>
- Disable unused features:
- Web management:
no web-management
- VSRP:
no router vsrd
- Telnet:
no telnet server
- Set the superuser enable password:
enable super-user-password <password>
- Add a user and enable login:
- Enable password encryption (requires v8.0.40 or later):
service password-encryption sha256
- Add user:
user <username> privilege 0 create-password <password>
- Privilege 0 is the highest.
- The default password hashing algorithm is MD5.
- The password can't contain spaces.
- Enable remote login:
aaa authentication login default local
- Make remote login enter priv exec mode:
aaa authentication login privilege-mode
- Enable priv exec mode login:
aaa authentication enable default local
- Enable login log messages and traps:
logging enable user-login
- Configure time zone (Norway):
- Time zone:
clock timezone gmt gmt+01
- Manual summer time:
clock summer-time
- Set the time (priv exec):
clock set <hh:mm:ss> <mm-dd-yyyy>
- Setup DNS:
- IPv4 DNS servers:
ip dns server-address <address> [...]
- IPv6 DNS servers:
ipv6 dns server-address <address> [...]
- Enable SSH:
- Delete the old key:
crypto key zeroize [rsa]
- Generate new key:
crypto key generate rsa modulus 2048
- Remove old public keys:
ip ssh pub-key-file remove
- Disable unused authentication methods:
ip ssh interactive-authentication no
ip ssh key-authentication no
- Make it secure:
ip ssh encryption aes-only
ip ssh encryption disable-aes-cbc
jitc enable
- Set the idle timer:
ip ssh idle-time <minutes>
(e.g. 15)
- Notes:
- SSH may crash if key-authentication is enabled but not configured.
- Both password and key based authentication is enabled by default.
- SCP is enabled by default.
- (Optional) Enable HTTPS:
- Delete the old SSL/TLS certificate:
crypto-ssl certificate zeroize
- Generate new SSL/TLS certificate:
crypto-ssl certificate generate
- Enable HTTPS:
web-management https
- Disable HTTP:
no web-management http
- Use local auth:
aaa authentication web-server default local
- Configure physical interfaces (
int eth <unit/slot/port> [to ...]
):
- Set the port name:
post-name <name>
- (SFP+ ports) Set the post speed and duplex:
speed-duplex 10g-full
- VLAN configuration: See separate section.
- Configure link aggregation:
- Create it:
lag <name> dynamic
- The "dynamic" can be omitted once created.
- Add ports to it:
ports ethernet <if> [to <if>]
- Set the primary port:
primary-port <if>
- All other ports will inherit the config for the primary port.
- Use frequent LACPDUs:
lacp-timeout short
- Deploy/enable it:
deploy
- Configure VLANs:
- Create VLAN:
vlan <VID> name <name>
- The name can be omitted once created.
- Create untagged og tagged ports:
<untagged | tagged> <if> [<if>*]
- (Optional) Set a dual mode VLAN (aka native VLAN):
- Add the port as tagged.
- Enter the physical interface configuration.
- Set it for the current interface:
dual-mode <VID>
- Enable spanning tree (same type as global):
spanning-tree
- Enable IPv6 forwarding:
ipv6 unicast-routing
- Configure in-band management interface and disable out-of-band interface:
- Disable the OOB mgmt. interface:
- Enter:
int man 1
- Disable:
disable
- Enter management VLAN config:
vlan <VID>
- Add router interface to the VLAN:
router-interface ve <VID>
- Exit VLAN config.
- Enter router interface:
int ve <VID>
- Set IPv4 address for it:
ip address <address>/length
- Set IPv6 address for it:
ipv6 address <address>/length
- Exit router interface.
- Add a default IPv4 route:
ip route 0.0.0.0/0 <gateway>
- Add a default IPv6 route:
ipv6 route ::/0 <gateway>
- Disable sending IPv6 RAs:
ipv6 nd suppress-ra
- Enable LLDP:
lldp run
- Configure spanning tree (802-1w):
- Enable globally:
spanning-tree single 802-1w
- Set priority:
spanning-tree single 802-1w priority 0
(0 for root)
- Set a port as edge port (aka portfast):
spanning-tree 802-1w admin-edge-port
- Enable root guard on a port:
spanning-tree root-protect
- Enable BPDU guard on a port:
stp-bpdu-guard
- Enable BPDU filter on a port:
stp-protect
- Show status:
show 802-1w
- (Optional) Configure NTP client:
- Enter config:
ntp
- Enable with server:
server <address>
- Show status:
sh ntp assoc
sh ntp status
- Save the config:
write memory
General Configuration
Basics
- Console:
- Enable logging to the serial console:
logging console
- Enable logging to SSH/Telnet:
terminal monitor
(in privileged exec mode)
- Hardware:
- Reboot:
boot system
- Show hardware:
sh chassis
- Log:
sh log
- CPU usage:
sh cpu
- Interfaces:
- Interface list:
sh int br
- Interface stats:
sh int
- Spanning tree:
- Link aggregation (LAG):
- File management:
- Show directory contents:
sh dir
- Show file contents:
copy flash console
- Config management:
- Save running config:
write memory
- Restore the startup config:
reload
- Transceivers:
- Show transceivers:
show media validation
- LLDP:
- Enable (config):
lldp run
- Show status:
show lldp
- Show neighbors overview:
show lldp neigh
- Show neighbor details:
show lldp neigh ports <port>
Ports
- Enable SFP+ ports:
speed-duplex 10g-full
Tasks
Reset Configuration
Run erase startup-config
and then reload
. Don't write mem
as it will recreate the startup config.
Features
Virtual Switch Redundancy Protocol (VSRP)
- A Ruckus-proprietary protocol for L2/L3 redundancy and failover.
- Enabled by default.
Theory
Using the CLI
Miscellaneous
- Brocade devices operate in cut-through switching mode instead of store-and-forward by default.
{% include footer.md %}